WordPress 内蔵の jQuery を使う際に注意すること

WordPress に内蔵されている jQuery を使うときに注意すること、それは「$」から始まるコードで jQuery を使うことができないということ。

WordPress 内蔵の jQuery は noConflict モードというものらしく、「$」の記述だけでは、 jQuery を呼び出すことができない。

じゃあ、どうするの?(;_;)っていうと・・・

「$」を「jQuery」に書き換えるか、「$」に jQuery オブジェクトを取得して、その内部の括弧内に通常の jQuery 呼び出しと同じ「$」から始まるコードを記述する。

コードは以下に記しておく。

jQuery(function($){
    // ここに $ から始まる jQuery コードを記述する
});

個人的なメモ書き程度だが、私のような WordPress 初心者の参考になったら幸いです。